HomeTroubleshooting

Windows Domain Logon Takes A Long Time

Like Tweet Pin it Share Share Email

I have been encountering this problem right from the start when I started systems administration. The problem is after adding a computer in a domain, when the computer is restarted and the logon screen appears (usually it’s the classic logon screen) and we want to change the logon domain. As soon as we click the drop down menu, it says “Please wait while the domain list is created" and it hangs on forever.

Basically this is a DNS issue. If the DNS of the system is not pointing to the DNS Server which includes a record of the domain, then it hangs on and does nothing. This is usually the case if we specify the DNS server as public internet servers rather than our own internal domain DNS server. So to solve this problem, just logon with the local administrator account and change the DNS address to the one which specifies the domain in its records.

To come out of the waiting loop, just press Ctrl-Alt-Del twice and the system will come out of the waiting loop.

Comments (9)

  • I have a problem with my Pc. My computer does not start after loading Xp. The xp gets loading only and log on windows does not appear. When i repaired it after an hour i encountered the same problem.Can u help me with my PC.

  • I guess I have the same proble windows xp sp2 loads and then blue screen wich would display the users kepps loading forever…

  • Please repair the operating system it will b ok….

  • If I may suggest dear, use a free cc cleaner software. Install it and it will help solve your nightmare.

  • @Mohamed
    How can one repair an operating system?

    @Master9888
    Please let me know how a cc cleaner can help solve this problem?

  • I had the same problem this morning. Other Google searches point to a DNS problem, where DNS for the XP box is not pointing to the correct DNS server. It gets stuck trying to bring up the domain list.

    I was told CTL-ALT-DELETE will help to bypass this situation.

    Side note: I use CCleaner quite often to remove temp files and do reg fixes, but rarely does it ever “fix” a problem I might be having. It has just as much chance of creating a problem as it does solving one.

    I’m remote so don’t have the CTL-ALT-DELETE option until I get in to work. I’ll report results.

  • If you have this problem and you have recently installed a domain with DNS, logging into the local machine will allow the new DNS settings to take effect (can be verified by running IPCONFIG /ALL). Then you log out and back in. It will then allow you to pick the domain without hanging.

  • simply, ignore this and press CTRL+ALT+DEL it will go and you can continue 🙂 enjoy

  • Good day
    As a GMs member and I attempt to log on, all too often it means a very long wait to connect, or, even worse unable to log-in

    Thankyou and cheers

    Dave

Comments are closed.

Popular Pages